jQuery 1.4 support in AIR 2.0 and ColdFusion Builder 1.0

Filed under: AIR, ColdFusion Builder, jQuery

comments (0) Views: 5,884

As you may know, Adobe has public betas for ColdFusion Builder, and AIR 2.0. Both of these toolsets will really advance the development of Rich Internet Applications: for Flex, for Flash, or for standards compliant HTML and Javascript. One thing that it looks like neither will ship with, however, is support for jQuery 1.4, released on January 14, 2010. jQuery is arguably one of the the biggest players, if not THE biggest, in the burgeoning JavaScript framework renaissance of the last 3 years.

While jQuery 1.3.2, the previous stable release, is a fine version, jQuery 1.4 comes with a slew of enhancements, speed increases, additional methods, and other higly valuable, and useful additions to the library. As I am not on either of the engineering teams, I don't know what factors go into a decision like this. However, if you feel strongly about jQuery, as I do, then please consider posting a request for both teams to support jQuery 1.4 in the final, shipping, versions of both pieces of software. Here's a link to the ColdFusion Builder forums, and here's a link to the AIR 2.0 forums. I've also taken the liberty of creating a post in each forum with a request for jQuery 1.4 support. You're welcome to comment in either the CFB request or the AIR 2 request.

Thanks for your time.

Amazon logo

If this article was interesting, or helpful, or even wrong, please consider leaving a comment, or buying something from my wishlist. It's appreciated!

comments powered by Disqus